Cedric discusses the inverted if statement that some languages that Perl and Ruby use. I personally like this feature a lot. You can argue that you don’t “need” it, but it brings a lot of readability to your code.
open $THEDOOR if $it_is_closed;
if ($it_is_closed) open $THEDOOR
I like the fact that we first read what we want to do, and then we move on to the condition.
I also like “unless”:
do something unless cond;
is a lot more readable than:
do something if !cond;
However, I do understand that you can get on a slippery slope adding keywords for things like this.