Women in Technology

Hear us Roar



Article:
  Configuring sendmail on Jaguar
Subject:   sendmail setup described fails for me
Date:   2002-09-19 14:30:03
From:   anonymous2
I followed the directions here for setting up sendmail by editing the config files and running the sendmail update script. For some reason the changes don't appear to take effect. I made the property entry into Netinfo as suggested as well.


Even running just the following recommended command results in the error regarding a world-writeable directory.


/usr/sbin/sendmail \ -OdontBlameSendmail=GroupWritableDirPathSafe \
-bd -q1h


451 4.0.0 /etc/mail/sendmail.cf: line 94: fileclass: cannot open '/etc/mail/local-host-names': World writable directory


What gives?


Has anyone else found this problem and perhaps a work-around? Any suggestions for things to check?


My config is a standard 10.2 install directly from Apple.


Thanks, Alex



Full Threads Oldest First

Showing messages 1 through 4 of 4.

  • sendmail setup described fails for me
    2003-09-30 09:04:37  anonymous2 [View]

    hey, when i send a mail , everything seems to work but i get EOT before gettting back the prompt. i check if i recieved the test on my other e-mail account but i did not get any!

    do you have an idea what is going on!
  • sendmail setup described fails for me
    2003-05-30 10:30:19  anonymous2 [View]

    Hey Alex,

    I get the same crash and error, but when I try to empty the trash in 10.2.6. Did you ever find out how to fix this?

    Thanks,

    AF
  • James Duncan Davidson photo sendmail setup described fails for me
    2002-09-24 12:07:08  James Duncan Davidson | O'Reilly AuthorO'Reilly Blogger [View]

    Your /usr/sbin/sendmail command there has the backslash character (\) twice. Are you executing the command all on one line with the backslash characters?

    Without the slashes, the command works just fine for me on a stock installed system (just reinstalled Jaguar on one of my test machines last night).

    Are there any clues in /var/log/mail.log?
    • sendmail setup described fails for me
      2003-10-30 00:01:15  dsgncr8or [View]

      Running, Apache/2.0.47 (Unix) DAV/2 installed in 10.2...

      getting this error in mail.log:

      Oct 30 01:33:40 DP500 sendmail[575]: dangerous permissions=40755 on queue directory /var/spool/clientmqueue/
      Oct 30 01:33:40 DP500 sendmail[575]: h9U7XeXZ000575: SYSERR(philliph): collect: Cannot write ./dfh9U7XeXZ000575 (bfcommit, uid=25, gid=25): Permission denied
      Oct 30 01:33:40 DP500 sendmail[575]: h9U7XeXZ000575: from=philliph, size=54, class=0, nrcpts=1, relay=philliph@localhost
      Oct 30 01:33:40 DP500 sendmail[575]: h9U7XeXZ000575: 0: fl=0x0, mode=100600: dev=14/2, ino=374631, nlink=0, u/gid=501/0, size=54
      Oct 30 01:33:40 DP500 sendmail[575]: h9U7XeXZ000575: 1: fl=0x2, mode=20620: CHR: dev=2/2963060, ino=37197572, nlink=1, u/gid=501/4, size=0
      Oct 30 01:33:40 DP500 sendmail[575]: h9U7XeXZ000575: 2: fl=0x2, mode=20620: CHR: dev=2/2963060, ino=37197572, nlink=1, u/gid=501/4, size=0
      Oct 30 01:33:40 DP500 sendmail[575]: h9U7XeXZ000575: 3: fl=0x2, mode=140000: SOCK [0]->[[UNIX: /var/run/syslog]]
      Oct 30 01:33:40 DP500 sendmail[575]: h9U7XeXZ000575: 4: fl=0x1, mode=20666: CHR: dev=2/2963060, ino=37198212, nlink=1, u/gid=0/0, size=0
      Oct 30 01:33:40 DP500 sendmail[575]: h9U7XeXZ000575: SYSERR(philliph): queueup: cannot create queue temp file ./tfh9U7XeXZ000575, uid=25: Permission denied

      any help would be usefull.