Women in Technology

Hear us Roar



Article:
  Replacing AppleScript with Ruby
Subject:   Can't include Appscript
Date:   2007-05-25 17:09:19
From:   devaulw
Response to: Can't include Appscript

The following worked fine with the gem. Rubyforge has more info.


#!/usr/bin/env ruby
begin
require 'rubygems'
rescue LoadError
end
require "appscript"
include Appscript
puts app('Finder').name.get