||10 Reasons We Need Java 3.0|
|Subject:||Idea about constructor naming|
|I've always wondered why constructors need to be named with the name of the class. Why not use a generic identifier: this() or ctor()...scratch that (no abbreviations right): constructor() for the default and overloads too. Whenever I've wanted to change the name of a class, it has seemed to me that having to rename all your constructors was kind of silly. Why are we forced to state the name of the class in multiple locations? Just a thought.|
Showing messages 1 through 1 of 1.
Idea about constructor naming
2005-02-22 05:24:45 bluetooth [View]