Article:
  Java Web Applications
Subject:   HTTP Status 404 - /
Date:   2006-08-19 16:32:55
From:   brahmadapa
Hi, I have installed jakarta-tomcat-5.0.30 first time and got the following status 404 error when I start the sever and tyring to browse localhost at: http://localhost:8080/ to view the tomcat home page.


Configuration instructions got it from the below webpage: http://www.moreservlets.com/Using-Tomcat-4.html#Enable-Root-Context


Error description:
HTTP Status 404 - /
-------------------------
type Status report
message /
description: The requested resource (/) is not available.
--------------------------


I have installed tomcat in my C drive as: C:\Tomcat 5.0 and my jdk available in: C:\j2sdk1.4.2_12 and I have set the user and environment varialbles as below:

JAVA_HOME: C:\j2sdk1.4.2_12
CATALINA_HOME: C:\Tomcat 5.0
CLASSPATH: ;.;C:\j2sdk1.4.2_12\lib\tools.jar;C:\Tomcat 5.0\common\lib\servlet-api;C:\Tomcat 5.0\common\lib\jsp-api
PATH: ;C:\j2sdk1.4.2_12\bin


Please suggest me.

Main Topics Oldest First

Showing messages 1 through 3 of 3.

  • HTTP Status 404 - /
    2007-01-25 03:47:57  aspai [View]

    Hi, I have installed jakarta-tomcat-5.0.30 first time and got the following status 404 error when I start the sever and tyring to browse localhost at: http://localhost:8080/ to view the tomcat home page.


    Configuration instructions got it from the below webpage: http://www.moreservlets.com/Using-Tomcat-4.html#Enable-Root-Context



    Error description:
    HTTP Status 404 - /
    -------------------------
    type Status report
    message /
    description: The requested resource (/) is not available.
    --------------------------

    I have installed tomcat in my C drive as: C:\Tomcat 5.0 and my jdk available in: C:\j2sdk1.4.2_12 and I have set the user and environment varialbles as below:

    JAVA_HOME: C:\j2sdk1.4.2_12
    CATALINA_HOME: C:\Tomcat 5.0
    CLASSPATH: ;.;C:\j2sdk1.4.2_12\lib\tools.jar;C:\Tomcat 5.0\common\lib\servlet-api;C:\Tomcat 5.0\common\lib\jsp-api
    PATH: ;C:\j2sdk1.4.2_12\bin

    pls suggest me
  • HTTP Status 404 - /
    2007-01-24 02:56:17  vijay-kumar-mishra [View]

    do one thing uninstall all the jdk n tomcat n reinstall all the software but dont delete the path's install in same place where that software was
  • HTTP Status 404 - /
    2006-08-25 12:01:14  dmersino [View]

    I just had this same problem. The message I got was identical and the command prompt which had the logs showed no exceptions at all. What's strange is that it was working just fine an hour prior. I tried rebooting, recompiling, etc., etc.

    Finally I remembered that I had changed the name of a Filter that I was using, that was referenced in the web.xml file. Once I corrected this in my web.xml, everything returned to normal.

    Normally when a class defn is incorrect you'll get a classNotFound or other exception in the logs. I don't know if this is just a bug in Apache when loading filters or if it will happen with other classes.

    So, you may want to try scanning your web.xml for any mis-spelled or missing classes that the server is trying to load.