Women in Technology

Hear us Roar



Article:
  Rolling with Ruby on Rails
Subject:   Error after generating Recipe controller
Date:   2005-10-15 19:30:55
From:   daveisaacs
Response to: Error after generating Recipe controller

I've double and triple checked against the downloadable version, and there is no problems that I can see.


However, when I tried starting the server from from downloadable version, I get error shown below. I am wondering if I have some sort of ruby/rails version incompatibility problem.


I am going to uninstall and start again from the beginning.


Thanks


Dave I


c:/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:139:in `activate': (Gem::LoadError)
Could not find RubyGem actionwebservice (> 0.0.0)
from c:/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:42:in `require_gem'
from ./script/../config/environment.rb:35
from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/loadpath_manager.rb:5:in `r
equire__'
from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/loadpath_manager.rb:5:in `r
equire'
from script/server:45



Full Threads Oldest First

Showing messages 1 through 2 of 2.

  • Error after generating Recipe controller
    2005-10-15 20:06:05  daveisaacs [View]

    OK, I seem to be working now. I uninstalled all my Ruby (version 1.8.2-14 Stable) and installed the latest version 1.8.2.15 Final.

    What do I think happened? Well, during install, I got the same problem that onestar was describing below. When executing "gem install rails --remote", I would only get rails_analyzer installed. So I instead forced the install of the 0.9.4 version by specifying "-v 0.9.4" on the command line. I guess rails 0.9.4 and ruby 1.8.2-15 do not play well together.

    Thanks

    Dave I
    • Error after generating Recipe controller
      2005-11-05 19:52:15  jeffvott [View]

      How did you eventually solve this problem. I am getting the same thing. What versions of Ruby/Rails did you end up using?