Women in Technology

Hear us Roar



Article:
  Rolling with Ruby on Rails
Subject:   Error create entire directory structure
Date:   2005-10-13 11:26:46
From:   onestar
Response to: Error create entire directory structure

In my ...ruby\bin directory lack "rails.cmd". And then I tried with "gem uninstall rails" and "gem install rails" printed as:


>C:\>gem uninstall rails
>C:\>"c:\ruby\bin\ruby.exe" "c:\ruby\bin\gem" uninstall rails
>Attempting to uninstall gem 'rails'
>Remove executables and scripts for
'rails_stat, bench, crawl' in addition to the gem? [Yn] y
>Removing rails_stat
>Removing bench
>Removing crawl
>Successfully uninstalled rails_analyzer_tools version 1.1.0


>C:\>gem install rails
>C:\>"c:\ruby\bin\ruby.exe" "c:\ruby\bin\gem" install rails
>Attempting local installation of 'rails'
>Local gem file not found: rails*.gem
>Attempting remote installation of 'rails'
>Successfully installed rails_analyzer_tools, version 1.1.0
>Installing RDoc documentation for rails_analyzer_tools-1.1.0...


I only saw rails with version 1.1.0 differnce from rails version 0.9.4 as instructions in the website.I also reboot my computer. Then I moved "C:\rails". I typed "rails cookbook".Then I met same error as I said.And my ...ruby\bin directory aslo lack "rails.cmd". I don't know reason why.


I also tried how to do as this website instructed as "gem install rails --remote" and then failed.


Are there difference 1.1.0 and 0.9.4? If so,can you give me file download rails version 0.9.4?
My address is ng_hong_duc@yahoo.com and also enjoy to know you.


I'm a new comer with Ruby On Rails need some help from you and everybody.


Thanks so much.


Full Threads Oldest First

Showing messages 1 through 3 of 3.

  • Curt Hibbs photo Error create entire directory structure
    2005-10-13 11:35:28  Curt Hibbs | O'Reilly AuthorO'Reilly Blogger [View]

    You're not getting Rails installed at all, its installing something called "rails_analyzer" instead. This is an issue with RubyGems (the Ruby package manager).

    I'm not sure why this is happening to you and not to me, but I'm sure there is a way to force it to install the latest version of Rails (which is now 0.13.1 rather than 0.9.4).

    Unfortunately I'm enroute to San Diego for the Ruby Conference so I can't be of much help at the moment. I'll post another response in the next day or so when I have a better answer for you.
    • Error create entire directory structure
      2005-11-01 12:36:30  isthisuniqueyet?? [View]

      The fix for me was to install rails via the following (where 0.14.2 is the current version)

      gem install Rails -b -v 0.14.2

      Hope this helps.
    • Curt Hibbs photo Error create entire directory structure
      2005-10-13 23:23:55  Curt Hibbs | O'Reilly AuthorO'Reilly Blogger [View]

      The RubyGems peopl tell me this means that you have a very old very of RubyGems. You should be using the latest version of the One-Click Ruby Installer which is 182-15.