Women in Technology

Hear us Roar



Article:
  Building J2EE Projects with Maven
Subject:   Trouble with the instructions.....
Date:   2005-09-14 09:05:55
From:   andrew.bruce.law
Hi again,


I've hit another problem (and solved it) with the instructions.


Problem: I tried to build the address module (by running '# maven' in the /j2ee-maven/maven-petstore-1.4/modules/address directory) but I hit a problem due to a lack of the xmldocuments-1.4.jar dependency. This does not exist in the ibiblio repository.


Solution: However, I cd'd to ./../xmldocuments directory, ran '# maven' there and this compiled and deployed the required jar to my local repository. Then I went back to the addresses module and the example ran as required.


Hope this helps.


Cheers, Andrew


Full Threads Oldest First

Showing messages 1 through 2 of 2.

  • Trouble with the instructions.....
    2005-09-14 09:25:02  andrew.bruce.law [View]

    Same thing happens when building the waf module on page 4. Again, solution is to go to the depended upon modules in turn and run their default targets

    Andrew
    • Trouble with the instructions.....
      2005-09-15 05:13:38  vmassol [View]

      Hi Andrew,

      This is simply because I haven't set up a reactor to build all the projects. Here what you can do to build it all at once:

      - go to the top level (for example in maven-xpetstore-ejb-3.1.3)
      - type "maven multiproject:install -Dmaven.multiproject.includes=**/project.xml"

      I guess I should add this in a maven.xml file at the top so that typing "maven" will simply work. Honestly I haven't fine-tuned the build; I just wrote the minimum for the article.