Women in Technology

Hear us Roar



Article:
  Apache Web-Serving with Mac OS X: Part 3
Subject:   Help!!! Error in the httpd file
Date:   2002-04-07 23:37:29
From:   plastic1
I keep getting this error: Syntax error on line 37 of /private/etc/httpd/httpd_macosxserver.conf:
Invalid command 'LoadModule', perhaps mis-spelled or defined by a module not included in the server configuration


Any Ideas on how solve this... I think I've corrupted the config files of apache trying to upgrade to apache 2.*. I have a mac os x server but when I tryed to install php4lib it broke all... I need your help, and also a good way to make work php, apache and mysql on my mac!

Full Threads Oldest First

Showing messages 1 through 1 of 1.

  • Morbus Iff photo Help!!! Error in the httpd file
    2002-04-16 17:09:01  Morbus Iff | O'Reilly Author [View]

    There have been reports of PHP having problems compiling with 2.0 on OS X - I'm not going to be getting into 2.0 discussions until Apple releases something official on their end (which hopefully will be with a 10.2 release, but if they don't, it won't surprise me).

    Generically speaking, a LoadModule error means either a) you're missing a matching AddModule line or b) the module in question is broken. If you had problems building PHP, then there's a good chance that the module on line 37 is the PHP module. Commenting it (by placing a # in front of that line) should give you (at the very least) a different error message.

    As for MySQL, there are instructions on how to install it on OS X in part five of this series.