Women in Technology

Hear us Roar



Article:
  Apache Web-Serving with Mac OS X: Part 3
Subject:   Web Server won't start - please help
Date:   2002-02-02 14:32:51
From:   pattyb777
I've been doing this series and loving it, but I think I made mistake in my httpd.conf file. The last time I stopped and started the web server, it tried to start but never actually started. It just keeps saying it is starting.


The section in question is as follows:
============
DocumentRoot "/Library/WebServer/Documents"


#
# Each directory to which Apache has access, can be configured with respect
# to which services and features are allowed and/or disabled in that
# directory (and its subdirectories).
#
# First, we configure the "default" to be a very restrictive set of
# permissions.
#
<Directory "/">
Options Indexes FollowSymLinks MultiViesw
AllowOverride None
Order allow,deny
Allow from all
</Directory>
==========


When empowering SSI, I edited this section by mistake. Can someone please check their file to see what it should say?


The other changes I made were to add these lines at the end of the other lines like them:



LoadModule php4_module libexec/httpd/libphp4.so


AddModule mod_php4.c


and uncomment these lines:


AddType application/x-httpd-php .php
AddType application/x-httpd-php-source .phps


All help will be appreciated!

Full Threads Newest First

Showing messages 1 through 2 of 2.

  • Web Server won't start - please help
    2002-02-02 21:23:01  rudar [View]

    Just started playing with this today, so I'm not sure I can spot the mistake right off. But if you run 'apachectl configtest' from the command line, it will tell you which line the syntax error's on...

    • checked back up file - d'oh!
      2002-02-03 03:23:04  pattyb777 [View]

      I didn't need the quotes around the slash in the directory listing. Forgot I had a back up file! All is well, thanks!

      Patty