Women in Technology

Hear us Roar



Article:
  Rolling with Ruby on Rails
Subject:   installation issues
Date:   2005-03-22 17:37:03
From:   mloco
I've been trying to install ruby and rails today on my XP machines, and i keep getting the same error, when I enter:


gem install rails --remote



c:/ruby/lib/ruby/site_ruby/1.8/rubygems/loadpath_manager.rb:5:in `require__': No such file to load -- iconv (LoadError) from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/loadpath_manager.rb:5:in `require'from c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.0.2/lib/active_suppo
rt/dependencies.rb:197:in `require'from c:/ruby/lib/ruby/gems/1.8/gems/actionmailer-0.8.0/lib/action_mailer
/vendor/tmail/quoting.rb:1 from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/loadpath_manager.rb:5:in `require__' from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/loadpath_manager.rb:5:in `require' from c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.0.2/lib/active_suppo
rt/dependencies.rb:197:in `require'from c:/ruby/lib/ruby/gems/1.8/gems/actionmailer-0.8.0/lib/action_mailer
/vendor/tmail/mail.rb:18
from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/loadpath_manager.rb:5:in `require__'
... 20 levels...
from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/cmd_manager.rb:90:in `process_args'
from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/cmd_manager.rb:63:in `run'from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/gem_runner.rb:9:in `run'from c:/ruby/bin/gem:11



i've tried to install locally but i get the same error after the gem packages are installed.

Full Threads Newest First

Showing messages 1 through 3 of 3.

  • Curt Hibbs photo installation issues
    2005-03-22 18:52:35  Curt Hibbs | O'Reilly AuthorO'Reilly Blogger [View]

    A new version of Rails was released today, and it appears that it has a problem installing on Windows. I was able to reproduce it, and I also found a workaround.

    The workaround is to explicitly install the old version of Rails. You'd first have to uninstall each of Rails components that got installed before it blew up, but I think it would be easier just to start over and uninstall Ruby (either from the start menu entry or from add-remove programs).

    Then reinstall Ruby and use this command to install Rails:

    gem install rails -v 0.10.1

    That worked for me. I will report this problem to the Rails team.
    • installation issues
      2005-03-23 10:06:42  sudaca [View]

      Thank you very much Curth. I was having the same problems and was going nuts trying to find any info on this.
      • mkdir not automatic?
        2005-03-28 06:28:01  Teiman [View]

        w:\>rails cookbook
        create
        Invalid argument - *

        w:\>dir

        Volume in drive W is PE Serial number is C531:B78D
        Directory of W:\*

        28/03/05 16:03 <DIR> .
        28/03/05 16:03 <DIR> ..
        0 bytes in 0 files and 2 dirs
        5.674.467.328 bytes free

        w:\>mkdir test

        w:\>rails test
        exists
        create app/apis
        create app/controllers
        create app/helpers
        create app/models
        ...

        Humm???... looks like the new version fail to create the start dir on windows.