Women in Technology

Hear us Roar



Subject:   Perl and CGI.pm
Date:   2002-01-13 11:39:55
From:   dtr
Response to: Perl and CGI.pm

I like the first informative installment and am looking forward to more. It took me a while to see that I needed to turn on sharing to serve localhost documents. You'll probably save people a lot of time.


I had the same problem with CPAN.


What I'd like to see is a simple set of directions for getting setup for a typical web use from OSX default. (Obviously, easier said than done). I'm trying to tackle getting perl scripts to run in a browser first.


For example, my httpd.conf was definitely not configured properly to start with. I thnk I've actually made things worse. All I need is a properly configured httpd.conf that does what it's supposed to--like run the printenv script that the computer was shipped with and which apparently worked out of the box for some people.


I still can't access the CGI-Execuatables directory from a browser, even though I reset the permissions and tried a few other thing, but I can access any html files fine. For a while, I was getting it to display the perl scripts as text (instead of executing), but allowing it to handle cgi somehow messed that up, too.


It just seems unnecessarilly messy that it didn't ship configured to do common things, and I am (obviously) frustrated. I don't mind learning how to configure things. In fact, I probably shoud. It just seems a bit still that everyone using it should have to.


Thanks for any straightforward help you can provide!