Women in Technology

Hear us Roar



Subject:   PHP 4.3.10 on OS X 10.2.8
Date:   2005-02-04 09:20:35
From:   rmwiseman
Response to: PHP 4.3.10 on OS X 10.2.8

A quick update for anyone who's interested: I discovered that a new version of Zend is required for 4.3.10. However, that didn't make it make!
Full Threads Oldest First

Showing messages 1 through 2 of 2.

  • PHP 4.3.10 on OS X 10.2.8
    2005-02-04 11:28:13  rmwiseman [View]

    Finally, a solution!



    From Daniel J. Luke's Weblog, http://www.geeklair.net/~dluke/archives/000526.html:



    "For anyone attempting to build php 4.3.10 (seeing as it fixes some security bugs). You might have problems with php-4.3.10/Zend/zend_strtod.c (at least, I did on my 10.2 system).



    "Line 131 seems to be the problem. Removing the "|| defined(__ppc__)" so that that define doesn't happen on my Mac OS X machine seemed to fix it."

    • PHP 4.3.10 on OS X 10.2.8
      2005-02-24 08:51:52  guillegv [View]

      Thanks to share your experience. I have been able to compile a version ad hoc. Definitively is impossible to compile php version 4.3.10 in Mac OS X 10.2.8. I also have used the php version 4.3.9.
      Thank you very much.
      Guillermo.