Article:
  Rolling with Ruby on Rails
Subject:   MySQL 4.1 using old passwords and rails 0.9.5
Date:   2005-01-27 10:04:30
From:   egard
I set the datbase.yml to root and a password, but I kept getting a ActiveRecord missing parameter error.


Apparently, rails wasn't connecting to the MySQL server with a password. Something to do with the using old passwords setting (hack for phpmyadmin)?


If you get these errors, just create a user for the rails database that has no password. With that user everything worked fine.


Ed

Full Threads Oldest First

Showing messages 1 through 1 of 1.

  • MySQL 4.1 using old passwords and rails 0.9.5
    2005-04-12 13:27:54  markstewart [View]

    I was running into the same thing. I was able to keep the password by enclosing it thus: 'password'