Women in Technology

Hear us Roar



Article:
  Migrating from Apache 1.3 to Apache 2.0
Subject:   Migration from 1.3 to 2.0.46 problems
Date:   2005-01-11 06:27:30
From:   surya24
I recently migrated from apache 1.3 on redhat7.2 to 2.0.46 on rhel 3.0 . I am running a proxy server with the new apache by calling a proxy.conf file with ProxyPass and ProxyPassReverse ,this will inturn redirect to another webserver. This setup was perfectly working in previous apache .But with the new apache it is not working . Just in case to check whether the other components are working fine or not I compiled the old apache again on this machine and checked ,which is working absolutely fine . SO I understand that some changes in the new apache are causing problem .
Normal functionality of the entire website is fine but when you click on a particular link to view an activex based document , it will downlaod an activex component and then tries to show the document and goes to page not found error . I enabled log level to debug but not able to find anything unusual. When something is wrong in my setup elsewhere why is the old apache working . I am trying to understand how to debug this problem . If someone can help me to debug I am ready to provide more information ..


Btw I am using the standard apache provide by redhat which is compiled with following options
$/usr/sbin/httpd -V
Server version: Apache/2.0.46
Server built: Sep 25 2003 09:26:39
Server's Module Magic Number: 20020903:4
Architecture: 32-bit
Server compiled with....
-D APACHE_MPM_DIR="server/mpm/prefork"
-D APR_HAS_SENDFILE
-D APR_HAS_MMAP
-D APR_HAVE_IPV6 (IPv4-mapped addresses disabled)
-D APR_USE_SYSVSEM_SERIALIZE
-D APR_USE_PTHREAD_SERIALIZE
-D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
-D APR_HAS_OTHER_CHILD
-D AP_HAVE_RELIABLE_PIPED_LOGS
-D HTTPD_ROOT="/etc/httpd"
-D SUEXEC_BIN="/usr/sbin/suexec"
-D DEFAULT_PIDLOG="logs/httpd.pid"
-D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
-D DEFAULT_LOCKFILE="logs/accept.lock"
-D DEFAULT_ERRORLOG="logs/error_log"
-D AP_TYPES_CONFIG_FILE="conf/mime.types"
-D SERVER_CONFIG_FILE="conf/httpd.conf"
------------------------------------------------------


Thanks in advance .


Rgds
Surya