Women in Technology

Hear us Roar



Article:
  Apache Web-Serving with Mac OS X: Part 1
Subject:   router setup/manual IP
Date:   2004-06-15 20:51:58
From:   bigcomposer
Ok -- I'm not sure if anyone is still reading this or not, but it's worth a shot.


I'm having some really strange things happening. I'm trying to get a simple server up and running using Jaguar. I've followed all of the instructions and understand most of it.


Problem #1
I have configured my router to pass requests to port 80 to a specified IP address. In my case, I'm using **.**.**.25 -- where the first three fields are the first three digits in the routers IP address (Using a simple Belkin router, I'm unable to change these anyway).


My problem occurs when I try to configure the server IP. When I set it to get an IP via DHCP, I have an internet connection; however, when I choose Configure IP Manual" in the Network Control Panel and enter all of the information, I lose internet connection. For the manual configuration, I type in the correct IP, Subnet Mask, and Router IP.


Interestingly, when I swith back to get IP via DHCP, the router sets the same address that I have in Manual and I then have an internet connection. Of course I don't want to have a dynamic IP on my server (ie, if my router has to be reset, etc... it may assign my server another IP).


Does anyone have an idea? Ive also tried using DHCP with a Manual Address with the same results....my computer doesn't see the router.


Problem #2
Just to test it out, I left my computer set to using "DHCP" to obtain the IP address. I then simply configured my router to pass web requests to the IP it assigned to that computer. However, when I tested it from another computer (ie, entered my permanent IP in a browser), I did not see my webpage. Instead, I got the front-page utility of my router! This freaked me out and I disabled websharing and the virtual server of my router. Again, any help will be very appreciated.



Any help will be appreciated!


thx,
Mike


Full Threads Oldest First

Showing messages 1 through 2 of 2.

  • router setup/manual IP
    2004-12-13 07:23:26  pezster [View]

    I am having the same problem with my Belkin router. From outside of the home I can't get to the website running on my machine. I am using a tool called noip.com which allows me to redirect the DHCP address to the internet. I always get the main router page. Have you fixed this issue?

    Thanks.
  • router setup/manual IP
    2004-07-08 08:37:08  guzzler [View]

    I'm having the very same problem :( I tried out the articles last night. All was well. This morning when I rebooted all my problems started. I followed instructions from art. 1-4 related to Jaguar and 5 and 6 from the earlier series coz i just couldnt wait! And now i've got the internet back but when i click on personal web sharing it gets stuck at starting... also i can no longer see my local site from the Sites folder and not from the Webserver/Documents folder.. Any help will be highly appreciated since the computer i've been fiddling around on is not mine!! :(