Women in Technology

Hear us Roar



Article:
  Build Your Own Apache Server with mod_perl
Subject:   MP_APXS MP_AP_PREFIX
Date:   2003-11-24 09:44:08
From:   anonymous2
When I try to run the Makefile.PL for mod_perl-1.99_11 (perl is 5.8.0) and use ../apache_1.3.29/src for APACHE_SRC, I get the following error:


!!! Unable to determine server version, aborting.
!!! Please specify MP_APXS or MP_AP_PREFIX.


Am I working with incompatible versions since they are different from the article's, or do I need to set additional parameters in the Makefile command? Thanks for any info.

Full Threads Oldest First

Showing messages 1 through 2 of 2.

  • MP_APXS MP_AP_PREFIX
    2003-11-24 09:57:21  anonymous2 [View]

    Me again (sorry for not registering --laziness). I've reverted to mod_perl-1.29, Makefile worked just fine. Hmmmm. Oh well.
    • David Wheeler photo MP_APXS MP_AP_PREFIX
      2003-11-24 09:59:30  David Wheeler | O'Reilly Author [View]

      Yes, you can only install mod_perl 1.99_xx against Apache 2.x. And you can only install mod_perl 1.xx against Apache 1.3.x.

      Regards,

      David