||Readable Java 1.5|
|Subject:||Interesting Ideas but...|
Response to: Interesting Ideas but...
I tend to agree with the above. There's nothing wrong with a for loop. Our in house codeing standards will never let us use the new version anyway. What I really argree with though is that your casting like syntax is just plain confusing. I don't really feel that similar syntax should only be distingishable because of context. I don't want to have to ask myself what context something is in, I just want to say "Ah it's a cast"
Hear us Roar