Subject:   Problem with Java 1.4.1 - The Solution?
Date:   2003-03-24 16:33:05
From:   anonymous2
Jbuilder 7 has the same problem. It donīt work with Java 1.4.1. But i have found a solution to fix.
Perhaps itīs the solution for Jrun 4?


Her it is:


from the MacFixIt site:


Fix for JBuilder 7 We previously reported that since Java 1.4.1 has been installed, JBuilder 7 stops working. Apple has now posted a developer note offering a solution:


In your JBuilder7 folder, navigate to JBuilder.framework/bin/
Open the jdk.config file in a text editor. You may need to do this from the shell with the sudo command depending on how the permissions to JBuilder7 are set. For example, type sudo vi jdk.config
Add the following line:
javapath /System/Library/Frameworks/JavaVM.framework/Versions/1.4.1/Libraries/libjvm_compat.dylib.
Save the file and launch JBuilder7 by double clicking the icon.


I hope it helps you to find the solution.