Women in Technology

Hear us Roar



Article:
  Apache Web-Serving with Mac OS X: Part 1
Subject:   127.0.0.1 works and localhost doesn't
Date:   2003-03-11 23:56:08
From:   anonymous2
hi -


when i try http://localhost/, i get popup 'The attempt to load 'Accessing URL:http://localhost/' failed. i checked netinfo manager and machine->localhost ip is set to 127.0.0.1. is there something else i need to set up? thanx for any suggestions. cheers, sf

Full Threads Oldest First

Showing messages 1 through 2 of 2.

  • 127.0.0.1 works and localhost doesn't
    2003-04-02 04:11:39  anonymous2 [View]

    type in:

    http://localhost/~[username]/

    of course, replacing the [username] with yours!

    as well, if you have a html file called index.html put into your Sites folder, this will be what comes up when you go to your root localhost directory as written above, otherwise a directory listing of your folders and files in Sites will show up in your browser
    • 127.0.0.1 works and localhost doesn't
      2003-05-31 09:09:21  anonymous2 [View]

      I have an additional question. Replacing the index.html in //localhost/~(tilde)username "sites" by my on website as well as replacing the content of library/Websites/documents gives me a 403 forbidden.
      I put my website up to the server with Fetch from a Powerbook within the network and otherwise by drag and drop from within the same disc. Nothing worked. Now I can't replace the backup files. Any idea what I'm doing wrong? I don't want to go to the terminal and destroy my whole system or Apache, because I'm very new to this.
      I'm working on a Dual 1000, OSX 10.2.6, behind a router, within a network of four Macs. IE 5.2 shows me my complete machine when calling localhost.
      My name is Wolf Dresp. I'm calling from Germany.