Article:
  X11 and OpenOffice on Mac OS X
Subject:   Problems getting started
Date:   2003-02-12 07:46:02
From:   parsimony
Well, I went through the prescribed steps without success and so then I tried the less prescibed steps (following the example shell commands for isolating errors-see last panel of Install Complete), still no success.


The steps I followed and results:


[localhost:~/Applications] david% cd /Applications/OpenOffice.org1.0.1/program
[localhost:/Applications/OpenOffice.org1.0.1/program] david% sh soffice
salogl.cxx/GetOGLFnc(): Could not load symbol glFlush
dyld: /Applications/OpenOffice.org1.0.1/program/soffice.bin Undefined symbols:
OpenGL undefined reference to _gll_noop expected to be defined in /usr/X11R6/lib/libGL.dylib
OpenGL undefined reference to _gll_pkey expected to be defined in /usr/X11R6/lib/libGL.dylib
Trace/BPT trap
[localhost:/Applications/OpenOffice.org1.0.1/program] david%


I also vi'ed the InstallLog, and everything installed correctly, so for some reason I'm getting, what appear to me a true novice, problems using or implementing the OpenGL aspects required for running OOo.


Thank you all in advance for your help,


david

Full Threads Oldest First

Showing messages 1 through 6 of 6.

  • Problems getting started
    2004-01-07 11:34:03  anonymous2 [View]

    Hi,

    for me it helped to remove /usr/X11R6/lib from the DYLD... path.

    Ref: http://simon.urbanek.info/simon/yawe/research/other.html

    Cheers,

    Uwe
    • openoffice won't launch in Panther X11
      2004-03-25 14:18:10  reche [View]

      Hi,
      I had openfOffice 1.0.3 working fine in my Mac until updated my system from OsX10.2.8 to the panher (OsX 10.3.2). Updating, the system was painful and openoffice is still not woking.
      The eror I get is the following:

      sh /Applications/OpenOffice.org1.0.3/program/soffice

      salogl.cxx/GetOGLFnc(): Could not load symbol glFlush
      dyld: /Applications/OpenOffice.org1.0.3/program/soffice.bin Undefined symbols:
      OpenGL undefined reference to _gll_noop expected to be defined in /usr/X11R6/lib/libGL.dylib
      OpenGL undefined reference to _gll_pkey expected to be defined in /usr/X11R6/lib/libGL.dylib
      Trace/BPT trap

      I seen that you have replyed to an e-mail saying that removing /usr/X11R^/lib from DYLD helped. However, how can I do this? I do not see any reference in soffice script that launch the.
      Regards, and thanks in advance for a positive consideration.
  • Problems getting started / solved !!!
    2003-06-19 07:15:22  anonymous2 [View]

    go to sourceforge.com an download
    XFree86_4.2.1.1.zip from this url
    or look for the XonX project:

    the file you need:
    http://prdownloads.sourceforge.net/xonx/XFree86_4.2.1.1.zip?download

    the project:
    http://sourceforge.net/projects/xonx

    extract and install it and
    then run X11 an then type:

    sh /Applications/OpenOffice.org1.0.1/program/soffice

    (there is a space after sh !!!)

    if this not work type this before:
    setenv DYLD_LIBRARY_PATH /Applications/OpenOffice.org1.0.1/program\
    :/Applications/OpenOffice.org1.0.1/program/filter:/usr/X11R6/lib


    Here is the original description:

    Running OpenOffice.org under XDarwin

    Hardy Mayer and Ed Peterlin

    1. X-windows for MacOS users

    This section briefly explains some of the background needed for running the beta
    version of OpenOffice.org1.0.1 (OOo) under Mac OS X (10.1 and 10.2).

    In addition to a standard MacOSX installation, it may be useful to have the Development tools installed (so that you have access to a gcc compiler and some other useful tools).

    You will need a current version of XFree86 and xDarwin installed which you can
    download and install from the following sites:


    http://www.xdarwin.org
    http://sourceforge.net/projects/xonx


    The main thing you need from this distribution is the X-server -- a unix program which allows you to launch various applications making use of the X11R6 windowing system --- a standard on most Unix systems, such as Linux, BSD, Solaris, HP-UX, AIX, etc.
    Since we do not want X to take over the complete display, we make use of XDarwin, a Darwin interface which allows X applications to run "rootless," i. e., on top of the MacOSX display, though they will look less elegant than standard ``Aqua'' applications (no pulsing blue buttons, etc.).

    In principle, one could run OOo directly under XDarwin, making use
    of the supplied startup scripts.

    From an active xterm:

    setenv DYLD_LIBRARY_PATH /Applications/OpenOffice.org1.0.1/program\
    :/Applications/OpenOffice.org1.0.1/program/filter:/usr/X11R6/lib

    cd /Applications/OpenOffice.org1.0.1/program
    sh soffice &
  • Problems getting started
    2003-02-14 09:30:02  yvesde [View]

    I got the same, I really don't know how can anyone run OpenOffice on a clean Apple 's X11 installation. OpenOffice is linked against the standard xfree86 librairies and replacing libGL.1.2.dylib from a standard install fixed that problem, if you want, I can give you the patch. Just ask:

    yves@gnu-darwin.org
  • Re: Problems getting started
    2003-02-12 21:21:02  o-maps [View]

    Well, I'm definitely not an expert here, and I haven't tried to install X11 and OOo yet (I will, though), but here's a guess:

    The OOo web site says that before installing X11 and OOo, you have to install Apple's Mac Developer Tools.

    http://porting.openoffice.org/mac/ooo-osx_downloads.html#applex

    I may have read somewhere that it is important (or at least desirable) to make sure it is the latest version of the developer tools (December 20002), too. The tools come on a separate CD with Jaguar, or you can download them here:

    http://developer.apple.com/tools/macosxtools.html

    I repeat, I'm just guessing, and would be happy to be corrected by a more knowledgeable reader.
    • Re: Problems getting started
      2003-04-19 06:49:36  germuska [View]

      I'm not particularly knowledgeable; I haven't ever gotten OpenOffice running either. But I just started with a clean Mac and installed X11, the X11 SDK, and the Developer tools before installing OpenOffice, and I get the same errors:

      salogl.cxx/GetOGLFnc(): Could not load symbol glFlush
      dyld: /Applications/OpenOffice.org1.0.1/program/soffice.bin Undefined symbols:
      OpenGL undefined reference to _gll_noop expected to be defined in /usr/X11R6/lib/libGL.dylib
      OpenGL undefined reference to _gll_pkey expected to be defined in /usr/X11R6/lib/libGL.dylib
      Trace/BPT trap


      I'm going to check out the alternate libGL suggestion from http://www.oreillynet.com/cs/user/view/cs_msg/14586