Women in Technology

Hear us Roar



Article:
  Serve Your iCal Calendars Using WebDAV
Subject:   apache + webdav + WebObjects
Date:   2002-10-27 05:45:05
From:   anonymous2
Lots of MacOSX geeks run WebObjects. This uses an adaptor which uses Apache API; if someone updates their Apache from eg 1.3.26 to a 2.x version, to support digest authentication etc as suggested, is this going to break WebObjects because of Apache API changes?

The source to the adaptor is included; but you'd need to know what to change...

Full Threads Oldest First

Showing messages 1 through 1 of 1.

  • apache + webdav + WebObjects
    2006-04-30 08:13:50  sweavo [View]

    It's possible to get digest auth working with 1.3.33, I don't know if it works with WebObjects though. Also, it puts out a warning about the module not using the extended API and possibly causing crashes, so caveat emptor, normal disclaimers apply, etc.

    Download the apache 1.3 source,


    $ cd apacheblah/src
    $ ./configure --enable-module=auth_digest --enable-shared=auth_digest

    ... EDIT the file modules/experimental/mod_auth_digest.c and global search and replace "digest_auth_module" with "digest_module"

    $ make -C modules
    $ mv modules/experimental/mod_auth_digest.so /usr/libexec/httpd
    $ apachectl configtest && apachectl graceful