Women in Technology

Hear us Roar



Article:
  Apache Web-Serving with Mac OS X: Part 2
Subject:   Still not getting .shtml to work right.
Date:   2002-09-25 16:45:04
From:   philocon
Response to: Still not getting .shtml to work right.

No chance to find the answer in the article. -
It's here:
Search for


'DirectoryIndex index.html'


add 'index.shtml'
so it reads


'DirectoryIndex index.html index.shtml'


For further explanation read


http://www.onlamp.com/pub/a/apache/2000/03/02/configuring_apache.html

Full Threads Oldest First

Showing messages 1 through 3 of 3.

  • Getting .shtml to work right!
    2006-06-22 05:24:21  carlco2 [View]

    sudo pico /etc/httpd/httpd.conf
    # DirectoryIndex: Name of the file or files to use as a pre-written HTML
    # directory index. Separate multiple entries with spaces.
    #
    <IfModule mod_dir.c>
    DirectoryIndex index.html index.shtml default.html default.shtml index.php index.cgi
    </IfModule>
    that should get about any default page working.

  • Still not getting .shtml to work right.
    2003-11-09 19:33:05  anonymous2 [View]

    I certainly had the same error, but adding index.shtml didn't help. It works as 127.0.0.1/index.shtml (so the shtml reading must be activated) but when i load 127.0.0.1 it goes to the Apache default page. My DirectoryIndex change looks like so:

    <IfModule mod_dir.c>
    DirectoryIndex index.html index.shtml
    </IfModule>

    Any suggestions?
  • Still not getting .shtml to work right.
    2003-03-29 22:55:31  anonymous2 [View]

    Thanks! That helped! :)